Human Drain Reverbnation

12/10/09

Edicion de video con OpenShot???


La siguiente información es basada en mi experiencia con el software, los post de la página oficial del proyecto y estos dos sitios:
http://www.adslfaqs.com.ar/openshot-video-editor-0922-editor-de-video-no-lineal-para-linux/
http://www.ubuntips.com.ar/2009/09/30/openshot-0-9-42-ahora-con-efectos-para-audio-y-video/
OpenShot video editorEs un ambicioso proyecto para lograr un editor no lineal de video para Linux fácil de usar y potente a la vez, en lo personal es un proyecto supremamente llamativo, recuerdo que traté de compilarlo en una de sus primeras versiones cuando aun estaba en pañales y lastimosamente me faltaban demasiadas librerias y en general, no pude en principio probarlo, para mediados del 2009 el proyecto se hizo más asequible y robusto, una de las sorpresas que me llevé fué el hecho de encontrar versión en paquetes .deb.
La primera versión que corrió sin demasiados fallos ni problemas en instalación o ejecución fué para mi la 0,9,22, que para ser instalada solo requiere que primero se instalen las dependencias y luego proceder al programa en si, los archivos que use para tal efecto los pongo a su disposición para descargarles en el siguiente link:
http://www.mediafire.com/file/jotznwhoqnn/openshot0,9,22.rar
Pantallazo de openshot en mi pc (versión 0,9,22)
Sin embargo, pasó poco tiempo para que se mejorara un poco más el proyecto y diera soporte a EFECTOS DE VIDEO Y AUDIO (Se han agregado 30 efectos de video y tres de audio, además de paquetes para idiomas adicionales)
Es posible instalarle en Ubuntu con paquetes deb ( programa y dependencias ) que encontrarán eligiendo su arquitectuta y versión en su página de descargas, donde también podrán descargar el paquete con el pack del idioma.
Otra alternativa de instalación (que es la que yo probé en mi pc) es hacerlo por medio del repositorio PPA de Launchpad, con el beneficio de tener la aplicación siempre actualizada. Para eso hay que agregar a /etc/apt/sources.list la siguiente linea:
deb http://ppa.launchpad.net/openshot.developers/ppa/ubuntu jaunty main
Autenticamos el PPA abriendo un Terminal y copiamos:
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys B9BA26FA
y luego instalamos con:
sudo aptitude update
sudo aptitude install openshot
Para hacer todo mas sencillo, si dispones de un pc sin conexion a internet en la house, dejo un backup de los .deb necesarios para openshot versión 0,9,43, por lo menos con todos los paquetes que yo tuve que instalar:
http://www.mediafire.com/file/hrlz5ugh3tz/openshot0,9,43_DEBs.rar
(RECUERDA QUE ESTA ES LA VERSIÓN 0,9,43 DE PPA!!!)
Lastimosamente, no todo es perfecto, de aqui en adelante va mi experiencia personal respecto a instalar la version de Openshot...

Pantallazo: paquetes a instalar∕desinstalar∕actualizar para Openshot

Una vez se ha agregado repositorio y llave, desde synaptic todo es perfecto y sencillito, asi que das click en openshot para actualizarlo, pero para lograrlo debes desinstalar algunos paquetes, actualizar otros e instalar unos más... (si al igual que yo, tenías instalado vlc por ejemplo)

Como soy demasiado curioso y lanzado, me dispongo a arriesgar las librerías libavcodec por ejemplo... así que acepto y todo muy sencillo: openshot actualizado, lo pruebo y funciona...

FUNCIONAN LOS EFECTOS DE VIDEO Y AUDIO!

Así que para ser justos, enumero lo bueno y malo que encontré en mi experimento:
Las ventajas que puedo citar DE la versión en desarrollo 0,9,43 (ppa):
  • Maneja todos los formatos de audio, video e imágenes que soporta ffmpeg.
  • Integración en Gnome con soporte de arrastrar y soltar.
  • Múltiples tracks.
  • Transiciones de video.
  • Superposiciones de imágenes y marcas de agua.
  • Plantillas de títulos.
  • Soporte de arrastrar y soltar en la linea de tiempo.
  • Desde esta versión agrega soporte a efectos de audio y video.
  • JODIDAMENTE FÁCIL DE USAR.
  • Interfaz sencilla.
  • OPEN SOURCE.
  • Ya se puede agregar a synaptic
Las DESventajas que puedo citar DE la versión en desarrollo 0,9,43 (ppa):

  • Aún está en desarrollo y por ello puede colgarse a veces.
  • Si usas ubuntu o cualquier debian−based a pesar de la sencillez para instalarle por repositorio, puedes JODER completamente tus codecs de video, en mi caso no puedo reproducir avi, mp4, flv con vlc ni con mplayer desde que lo instalé...La solución: O desinstalas todo openshot junto con los demás programas que te va a pedir que desinstales y vuelves a reinstalar codecs de audio, video y reproductores, O reproduces con gnome−mplayer.(Para los flv's no queda otra sino REINSTALAR ffmpeg si lo tenías instalado antes de instalar openshot o insalarlo para que conviertas los .flv a un formato de video conocido para luego reproducirlos con gnome−mplayer o usas el comando "ffplay video.flv").
  • A pesar de su sencillez y que los efectos son bastante interesantes, aún puede mejorarse, pero esa es la belleza del open−source, está en constante desarrollo así que es un punto en contra y a la vez en favor: es un proyecto bastante nuevo, no podrás hacer cosas como las que logras con "Lives" o "Cinelerra".
Por qué se desconfiguran los codecs???
libavdevice−unstrippedPor que el proyecto no usa las librerías que otros proyectos: requiere de dos librerías que dañan todo: libavcodec−unstripped, libavformat−unstripped, libavfilter−unstripped,, libavutil−unstripped
.

Si utilizas la versión 0,9,22 no vas a tener inconvenientes de tipo alguno, sin embargo en esa versión aún no están disponibles los efectos de video∕audio.

Good vibe!